新闻  |   论坛  |   博客  |   在线研讨会
iTOP-3568开发板NPU使用安装RKNN Toolkit Lite2
魔法城堡 | 2022-07-05 09:56:45    阅读:18   发布文章
1 输入以下命令安装 Python3.7、pip3 、gcc
apt-get install python3 python3-dev python3-pip gcc
2 安装相关依赖,输入以下命令:注:Toolkit-lite2 本身并不依赖 opencv-python,
但是在示例中需要用到这个模块,所以安装时也一并安装。如果不用到图像相关
的处理,可以不安装该依赖库
apt-get install -y python3-opencv
apt-get install -y python3-numpy
3 安装依赖包 setuptools,输入以下命令:
pip install -i https://pypi.tuna.tsinghua.edu.cn/simple setuptools

4 输入以下命令升级 pip

python3 -m pip install --upgrade pip

5 下载网盘资料中“iTOP-3568 开发板\02_【iTOP-RK3568 开发板】开发资料

\11_NPU 使用配套资料\04_RKNN-Toolkit-lite2 工具”中 rknn_toolkit_lite2.tar.gz 压

缩包,在 windows 上解压,然后通过 U 盘拷贝

rknn_toolkit_lite2/packages/rknn_toolkit_lite2-1.3.0-cp37-cp37m-linux_aarch64.whl

到开发板上。如下图所示:

6 安装 Toolkit-lite2,Debian10 ARM64 with python3.7

pip3 install rknn_toolkit_lite2-1.3.0-cp37-cp37m-linux_aarch64.whl

更多内容可以关注公众号:北京迅为


*博客内容为网友个人发布,仅代表博主个人观点,如有侵权请联系工作人员删除。

参与讨论
登录后参与讨论
推荐文章
最近访客